aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-02 20:21:12 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2013-09-03 18:11:42 +0800
commitdcb5ddc560b51cc5eb59a2ef27d91cf279271f36 (patch)
tree814d910bda10984a99afcde2ea1bf6558bac9fd0 /configure.ac
parent28be7462f56d5ab80c360d3090de6298a96a3e01 (diff)
downloadgsoc2013-empathy-dcb5ddc560b51cc5eb59a2ef27d91cf279271f36.tar.gz
gsoc2013-empathy-dcb5ddc560b51cc5eb59a2ef27d91cf279271f36.tar.zst
gsoc2013-empathy-dcb5ddc560b51cc5eb59a2ef27d91cf279271f36.zip
add empathy-geoclue-helper
Based on a proposed API on fdo#68658. May end up in geoclue at some point. https://bugzilla.gnome.org/show_bug.cgi?id=706627
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e0246ceda..c1522269a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,7 +69,7 @@ GOA_REQUIRED=3.5.1
# Optional deps
ENCHANT_REQUIRED=1.2.0
-GEOCLUE_REQUIRED=0.12
+GEOCLUE_REQUIRED=1.99.2
GEOCODE_GLIB_REQUIRED=0.99.1
ISO_CODES_REQUIRED=0.35
NAUTILUS_SENDTO_REQUIRED=2.90.0
@@ -425,11 +425,18 @@ AC_ARG_ENABLE(location,
if test "x$enable_location" != "xno"; then
PKG_CHECK_MODULES(GEOCLUE,
[
- geoclue >= $GEOCLUE_REQUIRED
+ geoclue-2.0 >= $GEOCLUE_REQUIRED
], have_geoclue="yes", have_geoclue="no")
if test "x$have_geoclue" = "xyes"; then
- AC_DEFINE(HAVE_GEOCLUE, 1, [Define if you have geoclue])
+ GEOCLUE_XML_FILE=`pkg-config --variable=dbus_interface geoclue-2.0`
+ if test "x$GEOCLUE_XML_FILE" = "x"; then
+ echo "Can't find dbus_interface variable in geoclue-2.0.pc"
+ have_geoclue="no"
+ else
+ AC_DEFINE(HAVE_GEOCLUE, 1, [Define if you have geoclue-2])
+ AC_SUBST(GEOCLUE_XML_FILE)
+ fi
fi
else
have_geoclue="no"