summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 57eba78..3dc3853 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,8 +6,16 @@ lib_LTLIBRARIES = falgproto/libfalgproto-0.1.la
EXTRA_DIST = \
autogen.sh \
+ $(top_srcdir)/.version \
$(NULL)
+# For git-version-gen
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
falgproto_libfalgproto_0_1_la_SOURCES = \
falgproto/falgproto.h \
falgproto/falgproto.c \