summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw44@gmail.com>2014-06-07 21:59:18 +0800
committerTing-Wei Lan <lantw44@gmail.com>2014-06-07 21:59:18 +0800
commit3c6035cfd2ee4cdfb1268d02486f9c741d0690e7 (patch)
treeac2698cc619eb645d7164b515cfbb8a761ddedcc /configure.ac
downloadfastalg-protocol-3c6035cfd2ee4cdfb1268d02486f9c741d0690e7.tar.gz
fastalg-protocol-3c6035cfd2ee4cdfb1268d02486f9c741d0690e7.tar.zst
fastalg-protocol-3c6035cfd2ee4cdfb1268d02486f9c741d0690e7.zip
Initial commit - import existing project filesv0.1.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..ae3f5d1
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,22 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+# vim: set sw=4 ts=4 sts=4 et:
+
+AC_INIT([fastalg-protocol], [0.1], [BUG-REPORT-ADDRESS])
+AC_CONFIG_SRCDIR([falgproto/falgproto.c])
+AC_CONFIG_HEADERS([config.h])
+
+AM_INIT_AUTOMAKE([foreign subdir-objects])
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_CC_STDC
+LT_INIT
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_HEADER_STDBOOL
+AC_TYPE_SIZE_T
+
+AC_CONFIG_FILES([Makefile falgproto/falgproto-0.1.pc])
+AC_OUTPUT